PIP-5048MK inverter

non-EV Solar, Wind and other renewable power sources
non-EV batteries and other energy storage stuff
Forum rules
Important!
This forum is for discussion of Non-EV matters.
affer
Groupie
Posts: 33
Joined: Sat, 11 May 2019, 20:06
Contact:

Re: PIP-5048MK inverter

Post by affer »

Sun is starting to produce power again.. here is my on and off-grid systems.. it might be an eastern project to put on more load :-D
Attachments
Screenshot 2020-03-26 at 19.23.39.png
Screenshot 2020-03-26 at 19.23.39.png (175.57 KiB) Viewed 57 times

jannie
Noobie
Posts: 6
Joined: Wed, 25 Mar 2020, 05:57
Real Name: Jan Hough

Re: PIP-5048MK inverter

Post by jannie »

XtractorFan wrote:
Wed, 25 Mar 2020, 18:37
I am a bit afraid to venture into ICC or similar
ICC and SolPipLog (the one I use) connects via USB (or serial)....
I noticed your com port is 8 - using CH340 have you tried changing its properties to use a lower port number?
My logging PC is quite old and has a 'proper' com port set as com1 for WathPower - if I need to use it.....
I initially had problems using USB/Serial adapters.
Thanks for your thoughts. I did try with the direct serial cable to my old laptop and port COM 1. The serial info is coming through as recorded my my 'Serial Port Monitor' program, but WatchPower is dead. :cry:

jannie
Noobie
Posts: 6
Joined: Wed, 25 Mar 2020, 05:57
Real Name: Jan Hough

Re: PIP-5048MK inverter

Post by jannie »

fllniks wrote:
Thu, 26 Mar 2020, 21:41
jannie wrote:
Wed, 25 Mar 2020, 06:14
It is working fine, but I am having a huge problem with WatchPower on my PC connecting to the inverter. When I do see serial communications (tested with Serial Port Monitor) the WatchPower program does not record any data. Can anyone give me a suggestion as to what to do next?
Try to following and see if it helps. I have noticed often watchpower won't record data if not run as administrator.
Close watchpower and make sure to exit it from taskbar too. Then right click watchpower and click "Run as administrator". Now, check if it is recording data or not.
Thanks for the advice. I have been doing just that. Still no joy. :cry:

paulvk
Groupie
Posts: 225
Joined: Fri, 23 Oct 2015, 23:45
Real Name: Paul
Location: Sydney

Re: PIP-5048MK inverter

Post by paulvk »

jannie
Have you set the baud rate in windows advanced settings to 2400 ?

jannie
Noobie
Posts: 6
Joined: Wed, 25 Mar 2020, 05:57
Real Name: Jan Hough

Re: PIP-5048MK inverter

Post by jannie »

paulvk wrote:
Yesterday, 06:03
jannie
Have you set the baud rate in windows advanced settings to 2400 ?
I had the baud rate at 9600 because I had seen that value somewhere (can't remember where). I changed it to 2400. No difference. :cry:

User avatar
coulomb
Site Admin
Posts: 3920
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Re: PIP-5048MK inverter

Post by coulomb »

jannie wrote:
Yesterday, 17:33
I had the baud rate at 9600 because I had seen that value somewhere (can't remember where).
The main part of firmware updates happens at 9600 bps, although the initial negotiations are at 2400 bps.
I changed it to 2400. No difference.
Watchpower should be setting the bit rate; no need for the user to do this.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

affer
Groupie
Posts: 33
Joined: Sat, 11 May 2019, 20:06
Contact:

Re: PIP-5048MK inverter

Post by affer »

my 5048mk is stucked in the read outs at the moment.

https://www.pvoutput.org/intraday.jsp?i ... t=20200329

it reads the same from the serial port even that that the sun has gone down. i use solpiplog for reading out, and nothing have changed in a few hours.

i can send commands to the MK, and it reports back firmware etc..

i am not able to get to the unit itself until at least after the 6. of april,

is there i command i can send to any one knows if it is possible to reboot the serial board, og i can do anything else remotely to get the issue fixed.

ive already rebooted the pi that interfaces to the MK

btw, it seems that i also had a dip today.

Post Reply