Check out these Chinese AC controllers

AC, DC, amps, volts and kilowatt. It's all discussed in here
User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Tue, 09 Oct 2012, 05:46

Hi there; I am thinking about purchasing a new, more powerful controller for the Quad 48V AC conversion. Looking all the available options, I found these Chinese controllers in Ali-Baba. Price is 1/2 to 1/3 of similar Curtis/Sevcon products.

http://www.alibaba.com/product-gs/62189 ... CTION.html

There are several related products at the bottom of the page, like a 96V AC controller. Brand is "Beijing Unison Electronics".

They refuse to send us the manual, not sure why. Maybe it's a communication problem...

What do you think about the specs, curves, etc...posted on the page?

User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Tue, 09 Oct 2012, 17:19

Like any purchaee there will be a risk but they look pretty good to me. They mention vector control and spend a few words on smooth throttle control so their heads are in the right space.
I'd go for it. This controller should solve many of the problems you had with the Kelly.
It would be so much easier with a manual though (as you said).
Maybe ask a harder question - like how does the controller get set up for a particular motor? When they balk at answering that you may be able to get at least part of the manual (if there is one).

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Wed, 24 Oct 2012, 06:49

Ok, we went for it. We should receive the controller soon.
Communication with the company was difficult, their English is very poor.
Price for the 300A & 400A is, suprisingly, the same (only $10 of difference).
We got a .pdf and a few pics (still no manual).

I'm posting the pics here; 1st software settings:
Image
Image

Cabling:
Image

And some general info:
Image
Image
Image
Image
Image
Image
Image
Last edited by peskanov on Wed, 24 Oct 2012, 14:50, edited 1 time in total.

User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Wed, 24 Oct 2012, 14:54

It looks pretty complete. I like the way they tell you the MOSFET and Bus Capacitor voltage rating used in each model - nothing to hide.

The two input pedal connections fit with the auto standard for a safe pedal system. The Vector control is most likely from the TI applications library so that should work well.

The only thing that seems odd is the claim that it's a Torque control system yet they provide configurable acceleration and de-acceleration ramp times - but it's probably just so you can have smooth control regardles of operator silliness.

Shame about all the black wires - that's going to be fun.

Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Wed, 24 Oct 2012, 20:27

Capacitors are rated a bit low...

I don't see the 300V? 400A model in the table?

Can I ask how much you paid for this? Looks like it'd be a decent buy if it works. What motor you going to use it with?
Rgds,
Stiive

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Thu, 25 Oct 2012, 01:22

Johny,
I don't think it is a "torque control" type controller. The few infos we gathered were ambiguous. We should receive the controller in a pair of weeks, we will see what the manual says (if there is a manual).

Stiive,
it's not 300V, a made a typo there, sorry. I meant 300A. They quote nearly the same price for both models, 300A and 400A.

LR8030A: 680 USD
LR8040A: 690 USD

Plus $150 shipped to Europe.

These controllers are 72V. They also have other models at 90V.


Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Thu, 25 Oct 2012, 13:53

peskanov wrote: Stiive,
it's not 300V, a made a typo there, sorry. I meant 300A. They quote nearly the same price for both models, 300A and 400A.

LR8030A: 680 USD
LR8040A: 690 USD

Plus $150 shipped to Europe.

These controllers are 72V. They also have other models at 90V.


Sorry, you did say 300 y, i just thought volts :P

Still a good buy for that price! Hopefully it works.
Unusual to see Chinese being conservative and rating the current at half the MOSFET capability, rather than a marketing ploy.

Let us know how it goes
Rgds,
Stiive

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Fri, 09 Nov 2012, 15:01

So, here is the new monster:
Image
They shipped it pretty fast. It weights about 5.5 KG and looks well built.
Image
As you can see, it's built over a thick 15mm aluminium slab.
Connector and USB/rs232 cabling came with the package:
Image

Now, the ugly part: no-info-at-all in the package. Every bit of info we have received about the controller was sent over email, and even that was very scarce.
The settings software did not run, as some security file included was out of date! Fortunately, we received the correct file after some emails.

Error codes: no info at all, first; after begging a few times, we got them, but it was not easy.
Parameter documentation: we have not received any info at all. But they told us they will provide something soon. I wonder if the have some inhouse documentation at all, I would not mind trying to get some translation from Chinese.

In summary, these guys are new to selling their product to the "general" public, and maybe new to selling their product out of China. difficult times ahead for us...

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Fri, 09 Nov 2012, 15:10

A picture of all the parameters; there a lot of misteries there. Default factory settings for all of them is "0" Image
Image

Image

Can anybody shed some lights in the following parameters?

- Mutual inductance (0-1H). I have no idea about that one.
- Rotor time constant (0-1H). Again, no idea.
- Motor pole pairs (0-100). It's a 4 pole motor, but they specify "pairs". Should we set "2", then?
- Motor reference flux current. I guess that one is nominal motor current?
Last edited by peskanov on Fri, 09 Nov 2012, 04:23, edited 1 time in total.

User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Fri, 09 Nov 2012, 15:15

Is there any mention of auto-tune, auto ID, auto anything?
It's very difficult to get those values any other way.
Yes set 2 pole pairs for a 4 pole motor.

In "Motor type" are there a lot in a list or something?

Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Fri, 09 Nov 2012, 15:19

peskanov wrote: A picture of all the parameters; there a lot of misteries there. Default factory settings for all of them is "0" Image
Image

Can anybody shed some lights in the following parameters?

- Mutual inductance (0-1H). I have no idea about that one.
- Rotor time constant (0-1H). Again, no idea.
- Motor pole pairs (0-100). It's a 4 pole motor, but they specify "pairs". Should we set "2", then?
- Motor reference flux current. I guess that one is nominal motor current?


Mutual inductance is the parameter often described as Lm, or Xm (must be converted to Henry) for a line frequency machine. You will have to do no load test to work out this.

Rotor time constant is the rotor inductance and can be worked out from a locked rotor test. The stator and rotor inductances are said to be equal as there is no way to discern between the two.

Pole pairs is 2 for 4pole motor.

Flux current is the magnetising current. That is the max current allowed to flux the motor.


Hope this helps
Rgds,
Stiive

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Fri, 09 Nov 2012, 15:38

Johny,
no autotune at all. Unison suggested we send the motor to China so they can fit the parameters, but that's an expensive solution!
In "motor type" you can see 3 types, IM/PMSM/BLDC. I uploaded the images again, it should be easier to read now.

Stiive,
thanks for your help; I think we have not enough expertise to learn those parameters from bench testings, but we can try.
It would be nice to learn those values from an existing 4 pole, 4 kw motor similar to ours. That way we would know we are getting meaninful results from our testings.





User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Fri, 09 Nov 2012, 16:39

peskanov wrote:It would be nice to learn those values from an existing 4 pole, 4 kw motor similar to ours. That way we would know we are getting meaninful results from our testings.
The config utility I use for my industrial controller lists over 100 Lenze motors of various power. The params include everything you need (I think). If we pick one of those we should be able to scale the values for yours. At least we will get close.

I'll be back....

User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Fri, 09 Nov 2012, 16:41

BTW For motor ref. flux current I would pick about half the nominal full rated current of your motor - not peak, current at RATED power.
For my 41 Amps at rated power, I see about 20 Amps magnetization current.

User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Fri, 09 Nov 2012, 16:53

OK, a typical Lenze 4kW ACIM.

4kW
400V
50Hz
4 Pole
1435 RPM @ full load
Cos Phi 0.82
Rated current 8.3A

Rotor resistance 0.543 Ohm
Stator Resistance 1434 mOhm
Stator Inductance 0.183 mH
Motor Leakage Inductance 11.8mH

Hopefully Stiive can help sort out how these might be used as a starting point.

In case I transcribed incorrectly.
Image

Edit: Changed motor current in my list
Last edited by Johny on Fri, 09 Nov 2012, 06:01, edited 1 time in total.

Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Fri, 09 Nov 2012, 17:23

Johny wrote: OK, a typical Lenze 4kW ACIM.

4kW
400V
50Hz
4 Pole
1435 RPM @ full load
Cos Phi 0.82
Rated current 8.3A

Rotor resistance 0.543 Ohm
Stator Resistance 1434 mOhm
Stator Inductance 0.183 mH
Motor Leakage Inductance 11.8mH


Looks okay to me. So i'd put in like this

- Mutual inductance (0-1H) = 0.0118
- Rotor time constant (0-1H) = 0.183

Johny wrote:BTW For motor ref. flux current I would pick about half the nominal full rated current of your motor - not peak, current at RATED power.
For my 41 Amps at rated power, I see about 20 Amps magnetization current.


Is this continuous mag current? Seems a bit excessive to me half the current going to magnetisation..

You should be able to work out the magnetisation current at rated load by calculation. I think i'm getting 6.17A @ 5% slip. Not 100% though
Rgds,
Stiive

Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Fri, 09 Nov 2012, 20:10

Stiive wrote:
Johny wrote: OK, a typical Lenze 4kW ACIM.

4kW
400V
50Hz
4 Pole
1435 RPM @ full load
Cos Phi 0.82
Rated current 8.3A

Rotor resistance 0.543 Ohm
Stator Resistance 1434 mOhm
Stator Inductance 0.183 mH
Motor Leakage Inductance 11.8mH


Looks okay to me.


Actually doesn't look okay to me... The mutual inductance seems too low for me
Rgds,
Stiive

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Tue, 13 Nov 2012, 13:52

Thanks Johny and Stiive;
we have a motor (in the electric tiler) which could give us some clues. It's 1.5kw, 48vac, 4 poles. We will request the needed data to the provider (it's not rewound, it was 48vac from origin), and will start testing the controller using that motor.

Once we get the thing working, will move to the 4kw one.

User avatar
Johny
Senior Member
Posts: 3729
Joined: Mon, 23 Jun 2008, 16:26
Real Name: John Wright
Location: Melbourne
Contact:

Check out these Chinese AC controllers

Post by Johny » Fri, 16 Nov 2012, 15:06

You can calculate required magnetisation current from Full Load Current (rated FLC) and cos phi.
Mag Current = FLC*sqrt((1-cos(phi)^2).

My motor FLC is 41A and cos phi is 0.78.
MagCurr = 41*sqrt(1-.78^2) => 41*.625 => 25.6A while the torque producing current is 41*.78 => 32A.

Curiously my controller Auto ID set mag current at around 21 Amps for 0 RPM (starting from stall).

User avatar
coulomb
Site Admin
Posts: 3780
Joined: Thu, 22 Jan 2009, 20:32
Real Name: Mike Van Emmerik
Location: Brisbane
Contact:

Check out these Chinese AC controllers

Post by coulomb » Sat, 17 Nov 2012, 04:31

Stiive wrote: Is this continuous mag current? Seems a bit excessive to me half the current going to magnetisation..

Don't forget that the currents add vectorially, and they are 90 degrees apart. So if the magnetising current is half the full load current, then the torque producing current is sqrt(1^2 - 0.5^2) = sqrt(3/4) = 0.866. So the power factor (cos phi) is 0.866/1.00 = 0.866, which is quite standard.

For Johny's example, the torque producing current would be sqrt(41^2 - 20^2) = sqrt(1281) = 35.8 A. So his power factor at full load would be 35.8 / 41 = 0.87.

[ Edit: 50% is Johny's rule of thumb; his actual motor uses a bit more than 50% magnetisation current and comes out at a power factor of 0.78, as indicated above. ]

That's the magic of vectorial current summing; you can use 50% of the current for magnetisation and still have 87% left over to do real work! Image
Last edited by coulomb on Fri, 16 Nov 2012, 17:36, edited 1 time in total.
Nissan Leaf 2012 with new battery May 2019.
5650 W solar, 2xPIP-4048MS inverters, 16 kWh battery.
1.4 kW solar with 1.2 kW Latronics inverter and FIT.
160 W solar, 2.5 kWh 24 V battery for lights.
Patching PIP-4048/5048 inverter-chargers.

Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Sun, 18 Nov 2012, 16:00

Here's how i see it.

NB: All calcs worked off an equivalent circuit diagram.

Parameters
Stator resistance = 0.641 ohm
Stator inductance = 2.9mH
Rotor resistance = 0.332 ohm
Rotor inductance = 1.2mH
Mutual inductance = 69.8mH

@ 60hz
Stator inductance = 1.106 ohm
rotor inductance = 0.464 ohm
mutual inductance = 26.3 ohm

Total impedance @ 2.2% slip is therefore 11.72+7.72i = 14.07 @ 33.6 deg Ohm

Total current for 266V phase-phase is 18.9 @ -33.6deg Amp
PF = 0.833 lagging

Voltage drop over stator = 24.2 @ 26.3deg V

Voltage over rotor and mag = 244.6V @ -2.5deg V

Magnetisation current = 9.3 @ -92.5deg A


According to Johnys "rule of thumb".
Mag current is 18.9*sqrt(1-0.8333^2) = 10.45A - close enough.


Now with the numbers Johny gave

Rotor resistance 0.543 Ohm
Stator Resistance 1434 mOhm
- Mutual inductance (0-1H) = 0.0118
- Rotor time constant (0-1H) = 0.183

@ 50hz
mutual inductance = 3.7ohm    -> TOO LOW!
rotor=stator inductance = 57.5 ohm

work out slip from shaft speed 1435rpm = 4.33%

rotor impedance is therefore = 12.53+57.5i
mag+rotor = 0.0562-3.94i

Total impedance = 1.49+53.6i -> You can already tell this is going to be bad

Total current @ 400V delta = 7.5 @ -88deg
PF = 0.028 lagging Image


Need I continue?.... As i said previously, The mutual inductance is too low compared to the other figures
Rgds,
Stiive

User avatar
BigMouse
Senior Member
Posts: 600
Joined: Thu, 28 Oct 2010, 02:39
Real Name: Vincent Tannahill
Location: Silicon Valley
Contact:

Check out these Chinese AC controllers

Post by BigMouse » Mon, 26 Nov 2012, 04:41

Stiive wrote:

Rotor time constant is the rotor inductance and can be worked out from a locked rotor test. The stator and rotor inductances are said to be equal as there is no way to discern between the two.
Johny wrote: OK, a typical Lenze 4kW ACIM.

4kW
400V
50Hz
4 Pole
1435 RPM @ full load
Cos Phi 0.82
Rated current 8.3A

Rotor resistance 0.543 Ohm
Stator Resistance 1434 mOhm
Stator Inductance 0.183 mH
Motor Leakage Inductance 11.8mH


Looks okay to me. So i'd put in like this

- Rotor time constant (0-1H) = 0.183


I'm confused. Shouldn't the rotor time constant be the rotor inductance divided by the rotor resistance (L/R)? Also, shouldn't the units be seconds rather than Henrys? Or am I completely missing something here?

If so, can the rotor time constant can be measured on the bench by simply placing an LCR meter on the motor and measuring the inductance of the stator?

User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Fri, 28 Dec 2012, 02:19

Time for a full report...of a total disaster.

When you deal with an unknown Chinese company, you know you are taking some risk, but we didn't expect the experience to be so catastrophic.

For starters, no manuals at all. Some documentation was promised, but all we got was a list of the error codes with very short explanations (badly translated, btw).
The configuration software didn't work. After many request, they did notice a certification file was outdated or incorrect and sent us the correct one.
When we looked at the connection diagrams, we noticed there were mismatches. They acknowledged the error and sent us the allegedly "correct" connections. Not at all. When we wired the controller, it reported several connection errors.
We took the voltmeter and checked the connections. Voltages did not match the diagram, and probably we were shorting several input lines.
Again, the guys from Unison acknowledged none of the existing diagrams were correct, and sent us the "correct" ones (at this point, we are not sure any of the 3 versions was totally ok).

Now, the really bad news. When trying to start the controller, we heard some "clack" sounds, a bit like a contactor going on or a cap blowing. As the unit is well sealed, we couldn't smell anything.
As the controller didn't work with any of the diagrams proposed, we asked for unit check & repairing. The guy from Unison refused to accept the machine back or perform any repairing.
We broke the guarantee seal and inspected the unit. It was short circuited; some structural pieces of metal were loosely attached to the case and a screw head touched a circuit layer, producing a short circuit.
We sent the pics to Unison. Again, no luck. They will not honor the guarantee. They suggested us to buy "one or more" units, at reduced price, so we have more probabilities to make any of them work!

Lessons to learn:
- Gold supplier means little or nothing in Alibaba.
- When buying a product through Alibaba, use the "official" channel. After contacting the Unison seller, we closed the deal outside the Alibaba system. Now we can not report the bad experience, as the product was not officially sold through Alibaba.


User avatar
peskanov
Groupie
Posts: 153
Joined: Sat, 15 Oct 2011, 00:55

Check out these Chinese AC controllers

Post by peskanov » Fri, 28 Dec 2012, 02:26

Pics of the board:
Image

Image

Stiive
Groupie
Posts: 295
Joined: Wed, 31 Dec 2008, 08:26
Location: Melbourne

Check out these Chinese AC controllers

Post by Stiive » Fri, 28 Dec 2012, 03:24

That sucks dude, sorry to hear.

peskanov wrote:
They refuse to send us the manual, not sure why. Maybe it's a communication problem...


Warning much?
Rgds,
Stiive

Post Reply